Ошибка при резервировании

ВиктАрина

New member
Регистрация
9 Ноя 2012
Сообщения
63
Реакции
0
Приветствую! После обновления 1С БУ до 3.0.37.29 выпадает ошибка:
09.12.2014 16:26:54 Не удалось подключиться к другой программе: {ОбщийМодуль.ОбщегоНазначенияКлиентСервер.Модуль(1075)}: Ошибка при вызове метода контекста (Connect)
Результат.Соединение = COMConnector.Connect(СтрокаСоединения);
по причине:
Произошла исключительная ситуация (V83.COMConnector.1): Ошибка разделенного доступа к базе данных
База данных заблокирована:
компьютер: ПК, пользователь: Администратор, сеанс: 6, начат: 09.12.2014 в 16:20:57, приложение: Тонкий клиент

Что это значит и как от этого избавиться?
 
Нужно больше информации.
1.Тип базы.
2. Версия платформы.
3. В каких случаях происходит.
а.Работают ли больше одного пользователя в базе на момент возникновения ошибки
4. Вы заходите под администратором?

Варианты (на первый взгляд):
1. Работает администратор (пользователь под админом) и временно использует COM соединение.
2. Предыдущие соединение завершилось с ошибкой и на сервере 1с висит не завершенный процесс. (завершить процесс через Администрирование -->Активные пользователи.)
3. Нет прав на сетевой вход (Конфигурация компьютера-->Конфигурация Windows-->Параметры безопасности-->Локальные политики-->Назначение прав пользователя-->Доступ к компьютеру из сети)
4. Бывает из-за фоновых заданий. (перераспределить время выполнения фоновых(регламентных) заданий)
5. Возможно требуется перерегистрация COM компонента на сервере 1с.

Вангую: т.к. 3.0.37 перешла на платформу 8.3.5, то потребовалось переустановить платформу, соответственно во время установки не установили COM компонент.
 
Последнее редактирование:
Нужно больше информации.
1.Тип базы.
2. Версия платформы.
3. В каких случаях происходит.
а.Работают ли больше одного пользователя в базе на момент возникновения ошибки
4. Вы заходите под администратором?

Варианты (на первый взгляд):
1. Работает администратор (пользователь под админом) и временно использует COM соединение.
2. Предыдущие соединение завершилось с ошибкой и на сервере 1с висит не завершенный процесс. (завершить процесс через Администрирование -->Активные пользователи.)
3. Нет прав на сетевой вход (Конфигурация компьютера-->Конфигурация Windows-->Параметры безопасности-->Локальные политики-->Назначение прав пользователя-->Доступ к компьютеру из сети)
4. Бывает из-за фоновых заданий. (перераспределить время выполнения фоновых(регламентных) заданий)
5. Возможно требуется перерегистрация COM компонента на сервере 1с.

Вангую: т.к. 3.0.37 перешла на платформу 8.3.5, то потребовалось переустановить платформу, соответственно во время установки не установили COM компонент.

Отвечаю подробно:
1. Бухгалтерия предприятия, редакция 3.0 (3.0.37.29)
2. 1С:Предприятие 8.3 (8.3.5.1248)
3. В базе работаю я одна всегда.
4. Захожу под администратором.

Как установить этот COM компонент?!?! Какие там галочки надо нажать, что б все установилось правильно? (Смотрела инструкцию установки платформы в справке 1С. Выставила галки так же, как у них в инструкции).
Спасибо!
 
1.Какой тип базы используется?
2. Какая топология сети?

Установка и регистрация COM компонента:
1. При установки платформы Выбрать объект как на рисунке:
aa2a467e3bdb.png

2. В Пуск выбрать этот пункт:
8974fedba4c2.png

3. Перезапустить сервер.

По сути 1с "ругается" на пользователя в системе (в данном случае на Вас), возможно, у Вас в данный момент открыт какой-нибудь документ, или один и тот же документ открыт несколько раз, или Вы выполняете, на момент возникновения ошибки, какие-то операции, или открыто несколько копий 1с (1с запущена несколько раз). В момент возникновения ошибки обратите внимание на сеанс
компьютер: ПК, пользователь: Администратор, сеанс: 6, начат: 09.12.2014 в 16:20:57, приложение: Тонкий клиент
. А потом зайдите в Администрирование-->Поддержка и обслуживание-->Активные пользователи и посмотрите какие сеансы начаты и какой сеанс вызывает ошибку доступа к данным:

ae7d2e5cb89d.png


Если не разберетесь, то скидывайте опять номер сеанса, на который "ругается" 1с и скриншот с раздела "Активные пользователи", а лучше использовать TeamViewer, процесс диагностики пойдет быстрее.
 
Последнее редактирование:
Назад
Сверху